Feature-based CAM software for mills, multi-tasking lathes and wire EDM

www.featurecam.com
FeatureCAM

Copyright © 1995-2015 Delcam Ltd. All rights reserved.

Delcam Ltd has no control over the use made of the software described in this manual and cannot accept responsibility for any loss or damage howsoever caused as a result of using the software. Users are advised that all the results from the software should be checked by a competent person, in accordance with good quality control procedures.

The functionality and user interface in this manual is subject to change without notice in future revisions of the software.

The software described in this manual is furnished under licence agreement and may be used or copied solely in accordance with the terms of such licence.

Delcam Ltd grants permission for licensed users to print copies of this manual or portions of this manual for personal use only. Schools, colleges and universities that are licensed to use the software may make copies of this manual or portions of this manual for students currently registered for classes where the software is used.

Acknowledgements

This documentation references a number of registered trademarks and these are the property of their respective owners. For example, Microsoft and Windows are either registered trademarks or trademarks of Microsoft Corporation in the United States.

FeatureCAM Version: 2015 R3 Date: 26 March 2015 12:22
# Contents

## Getting started in FeatureCAM

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Starting FeatureCAM for the first time</td>
<td>2</td>
</tr>
<tr>
<td>Creating a new file</td>
<td>4</td>
</tr>
<tr>
<td>Screen layout</td>
<td>5</td>
</tr>
<tr>
<td>Getting help</td>
<td>6</td>
</tr>
</tbody>
</table>

## Introduction to 2.5D milling

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Defining the Stock</td>
<td>8</td>
</tr>
<tr>
<td>Creating the features</td>
<td>9</td>
</tr>
<tr>
<td>Viewing the part</td>
<td>12</td>
</tr>
<tr>
<td>Simulating the toolpaths</td>
<td>13</td>
</tr>
<tr>
<td>Order of manufacturing operations</td>
<td>15</td>
</tr>
<tr>
<td>Automatic ordering operations</td>
<td>16</td>
</tr>
<tr>
<td>Manual ordering options</td>
<td>18</td>
</tr>
<tr>
<td>Part documentation</td>
<td>19</td>
</tr>
<tr>
<td>Controlling the strategies</td>
<td>20</td>
</tr>
<tr>
<td>Generating NC code</td>
<td>21</td>
</tr>
<tr>
<td>Tool mapping</td>
<td>22</td>
</tr>
<tr>
<td>Changing the post processor</td>
<td>22</td>
</tr>
<tr>
<td>Saving the NC code</td>
<td>23</td>
</tr>
</tbody>
</table>

## Introduction to turning

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Defining the stock</td>
<td>24</td>
</tr>
<tr>
<td>Preparatory steps</td>
<td>26</td>
</tr>
<tr>
<td>Defining the geometry</td>
<td>27</td>
</tr>
<tr>
<td>Creating the features</td>
<td>30</td>
</tr>
<tr>
<td>Viewing the part</td>
<td>35</td>
</tr>
<tr>
<td>Simulating the toolpaths</td>
<td>37</td>
</tr>
<tr>
<td>Order of manufacturing operations</td>
<td>38</td>
</tr>
<tr>
<td>Part documentation (Turning)</td>
<td>40</td>
</tr>
<tr>
<td>Generating NC code (Turning)</td>
<td>41</td>
</tr>
<tr>
<td>Changing the post processor</td>
<td>41</td>
</tr>
<tr>
<td>Saving the NC code</td>
<td>42</td>
</tr>
</tbody>
</table>

## Introduction to turn/mill

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preparatory steps</td>
<td>44</td>
</tr>
<tr>
<td>Defining the geometry</td>
<td>44</td>
</tr>
<tr>
<td>Creating the features</td>
<td>47</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Viewing the part</td>
<td>48</td>
</tr>
<tr>
<td>Creating three radial holes on the face</td>
<td>49</td>
</tr>
<tr>
<td>Engraving the face</td>
<td>50</td>
</tr>
<tr>
<td>Creating three slots</td>
<td>53</td>
</tr>
<tr>
<td>Simulating the toolpaths</td>
<td>54</td>
</tr>
<tr>
<td><strong>Introduction to 3D milling</strong></td>
<td>55</td>
</tr>
<tr>
<td>Defining the Stock</td>
<td>56</td>
</tr>
<tr>
<td>Defining the geometry</td>
<td>56</td>
</tr>
<tr>
<td>Creating the bottle surface</td>
<td>60</td>
</tr>
<tr>
<td>Viewing the part</td>
<td>61</td>
</tr>
<tr>
<td>Creating a surface milling feature</td>
<td>63</td>
</tr>
<tr>
<td>Simulating the toolpaths</td>
<td>66</td>
</tr>
<tr>
<td><strong>Introduction to wire EDM</strong></td>
<td>67</td>
</tr>
<tr>
<td>Defining the stock</td>
<td>67</td>
</tr>
<tr>
<td>Creating the profile</td>
<td>68</td>
</tr>
<tr>
<td>Creating a wire EDM feature</td>
<td>70</td>
</tr>
<tr>
<td>Simulating the wire EDM toolpath</td>
<td>71</td>
</tr>
<tr>
<td>Generating NC code</td>
<td>73</td>
</tr>
<tr>
<td>Adding a taper angle</td>
<td>74</td>
</tr>
<tr>
<td><strong>Index</strong></td>
<td>77</td>
</tr>
</tbody>
</table>
FeatureCAM is a CAD/CAM software suite that automates machining and minimizes programming times for parts on mills, lathes, and wire EDM.

*The functionality available to you depends on which components you have licensed.*

FeatureCAM generates toolpaths based on the features of the part, and automatically selects appropriate tools, determines roughing and finishing passes, and calculates feeds and speeds.

This *Getting Started* guide provides step-by-step instructions that highlight some of the features of this versatile software. FeatureCAM is very easy to use, and does not require any specialist computing knowledge.
Starting FeatureCAM for the first time

1. From the Start menu, select All Programs > FeatureCAM > FeatureCAM.

   ![You can also start the program by double-clicking the FeatureCAM icon on your desktop.]

   The first time you start FeatureCAM, it runs a program to create the tools and materials database.

2. Click OK to begin the configuration. This displays the Tool and Material Setup dialog.

3. To create a local database, select On my local computer.

   If you want multiple computers to share the same tool and material information:
   a. Select On another computer that I will access over a network.
   b. Click the Browse button, and use the Database Location dialog to select the folder where the database is located.

   ![You need to create a database folder on your network first, and then copy an empty MDB database from the FeatureCAM CD-ROM to this location. The default database is created by MS Access, and should be accessed using the MS Jet database driver. You may use a different database type, such as MS SQL Server. For more information, refer to the online help.]

   ![You need to have the Shared Network Database module to use this option.]

4. Click Next.
5 Choose the tools to load:

![Tool and Material Setup dialog box]

**Inch** - loads only the inch tools.
**Metric** - loads only the metric tools.
**Both** - loads both inch and metric tools.

6 Click Next.

7 If you chose to load both tool types, you are asked which tool type you use more often. Select **Inch** or **Metric**, and click Next.

8 Click Finish to initialize the database.

*The tools database specifies the set of tools used by FeatureCAM to perform manufacturing operations. For best results, use the Tool Manager (available from the Manufacturing menu) to customize the database to reflect the tools in your shop.*
Creating a new file

Starting FeatureCAM displays the New Part Document Wizard.

2. Choose a Type of Milling Setup.

3. Select the Unit of Measure (Inch or Millimeter).
   - You can change the default dimension units later, by selecting Options > File Options from the menu.

4. Click Finish.
Screen layout

The FeatureCAM interface contains a number of standard Windows elements, such as toolbars, dialogs, context menus, and wizards.

1. **Title bar** displays the type of part setup in round brackets, in this case (Milling), and the name of your part file in square brackets, in this case [FM1]. When you have any unsaved changes in your part file, an asterisk (*) is displayed next to its name.

2. **Menu bar** provides access to a number of menus. Selecting a menu, such as View, opens a list of associated commands and sub-menus. Sub-menus are indicated by a small arrow to the right of the text. For example, selecting View > Principal Views displays a list of commonly used views.

3. **Toolbars** provide quick access to the most commonly used commands in FeatureCAM.

4. The graphics window is the main working area.

5. **Toolbox** window with the Steps panel, Part View panel, and Browser.
The **Steps** panel contains an ordered list of steps for creating part programs. Each step is a wizard that presents a series of dialogs for each process. They are listed in the order in which you should use them during the process of creating a part program.

The **Part View** panel provides a hierarchical view of the part.

The **Browser** contains information on the latest features available in FeatureCAM, including example files that you can load straight into FeatureCAM.

6 **Results** window contains the automatically generated documentation including tooling lists, setup sheets, and the NC part programs. Selecting one of the tabs at the bottom of the window changes the content of this window.

7 **Assistance** bar displays help for the current command.

8 **Feature/Geometry Edit** bar lets you select and edit a feature, or enter the point locations and parameters for geometry creation.

9 **Status** bar shows your current drawing units, tool crib, and post processor settings, as well as your keyboard status and information about the simulation when you run one.

---

**Getting help**

FeatureCAM provides a variety of ways for you to get help. Context-sensitive help displays help for the current task. You can also refer to the numerous examples in the **Examples** folder, located in the FeatureCAM root directory. Finally, if you cannot find an answer to your question, you can visit our website or contact our technical support.

**Online help**

The online help documentation is your primary source for in-depth technical information about FeatureCAM. It covers all FeatureCAM modules, and is accessed from the **Help** menu, or by clicking on the toolbar.

**Context-sensitive help**

You can use one of the following methods to get help relevant to the current task:

- Some commands automatically display the help in the **Assistance** bar.
• Hovering the mouse over a toolbar icon displays a brief description.

• Pressing F1 displays the relevant help page.

• Most FeatureCAM dialogs have the Help button. Clicking it displays the relevant help page.

• Click the Context Help button on the toolbar. When the cursor has changed to a question mark (?), click a menu item, button or dialog for more information.

Links
You can find FeatureCAM information from the Help menu:

• Help > FeatureCAM on the Web for product news, online support, training information, discussion forum, and mailing list.

• Help > Check for a FeatureCAM Patch for product updates.

• Help > FeatureCAM API Help for documentation on the FeatureCAM API (Application Programming Interface).

Technical Support
If you have any questions related to FeatureCAM, which you cannot find an answer to in the documentation, you can contact the Delcam technical support service. Email support@featurecam.com, describing your problem as precisely as possible. This support is free for the first 60 days after your initial purchase and 30 days after the purchase of an upgrade.
Introduction to 2.5D milling

This example shows you how to create some simple features, generate toolpaths and output the toolpaths used to machine the part.

1 Start FeatureCAM (see page 2).
2 Create a new file (see page 4).
3 Create the stock (see page 8).
4 Create the features (see page 9).
5 Viewing the part (see page 12).
6 Simulating the toolpaths (see page 13).
7 Part documentation (see page 19).
8 Controlling the automation (see page 20).
9 Changing the post processor (see page 22).
10 Generating NC code (see page 21).
11 Tool mapping (see page 22).
12 Saving the NC code (see page 23).

Defining the Stock

The stock is the initial material from which you cut your part. When you create a new part, the Dimensions page of the Stock wizard is displayed. It enables you to determine the shape and dimensions for the stock, the stock material, part program zero, and the coordinate system for modeling.
1 On the Dimensions page of the Stock wizard:

   a Enter a Thickness of 1 (25 mm).
   b Enter a Width of 4 (100 mm).
   c Enter a Length of 5 (120 mm).
   d Click Finish.

2 Click OK to accept the default values of the Stock wizard.

Creating the features

This step shows how to create Hole and Rectangular Pocket features.

<table>
<thead>
<tr>
<th>English units</th>
<th>Metric units</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Diagram" /></td>
<td><img src="image2" alt="Diagram" /></td>
</tr>
</tbody>
</table>

1 Create a Hole feature.

   a Click the Features step in the Steps panel.
   b In the New Feature wizard, select Hole in the From Dimensions section, and click Next.
   c Enter a Diameter of 0.5 (12 mm), and click Next.
d Enter a hole center location of X 1.0 (25 mm) and Y 1.0 (25 mm), and click Next.

This displays the Strategies page. This page controls the types of operations used to cut the feature. The default operations for a Hole feature are to spot drill and then drill the hole. If the Hole has a chamfer, the default is to cut the chamfer with the spot drill operation.

e Accept the default strategy settings by clicking Next.

The Operations page shows a summary of the operations to cut the feature, the automatically selected tools, and the feeds and speeds.

From the Finish menu button select the Finish option.

2 Create a Rectangular Pocket feature.

a Click the Features step in the Steps panel.

b In the New Feature wizard, in the From Dimensions section, select Rectangular Pocket, and click Next.

c Accept the default dimensions by clicking Next.

d Enter a pocket location of X 0.75 (15 mm), and Y 2.5 (60 mm), and Z 0 (0 mm), and click Next.
The Strategies page shows that roughing and finishing operations are created.

3. Click the Finish button.

4. Use the Features step to create another Rectangular Pocket the same dimensions as the first, but positioned at \( X=2.5 \) (55 mm), \( Y=0.5 \) (15 mm).

5. Select File > Save, and save the part as milling.fm.
Viewing the part

To look at the part in a different orientation you can select one of the standard predefined views. These options are available from the Standard toolbar:

1. To change the view to an isometric view, click the Isometric button on the Standard toolbar.

2. To change the view to a front view, from the Principle View menu button, click the Front button.
3 Click the Isometric button to return to the isometric view.

Simulating the toolpaths

Now you have created the features, FeatureCAM automatically:

- Selects the most appropriate tools and operations;
- Recommends machining strategies;
- Calculates speeds and feeds;
- Generates toolpaths and creates the NC code.

To view the simulated toolpath:

1 Click the Toolpaths step in the Steps panel. This displays the Simulation toolbar.

2 Select the 3D Simulation option, and then click Play to start the simulation. If the Automatic Ordering Options dialog appears, click OK to close it. This accepts the default ordering options.

This displays a solid 3D rendering of the cutting process.
If all tools are displayed in gray in the simulation, select Options > Simulation > General from the menu, and select the Tool Colors option, then click OK to close the dialog. This displays tools in different colors so you can see which features are machined by each tool.

Click the Play button on the Simulation toolbar to see the changes.

3 Click the Play to Next Operation button. This displays the spot drill operation.

4 Repeat step 3 to view each subsequent operation until you complete the simulation.

5 Click Eject. This removes the Simulation toolbar.
Order of manufacturing operations

The Op List tab in the Results window shows all of the operations needed to machine the features. A yellow warning sign next to an operation indicates a potential problem with that operation. In this case, if you see any warnings ignore them.
This section looks at:

- The automatic ordering options. (see page 16)
- The manual ordering options. (see page 18)

**Automatic ordering operations**

You can control the automatic ordering of operations by using either rules or operation templates. The turning tutorial looks at operation templates (see page 38).

1. Select the **Automatic Ordering** option on the Op List tab. This ensures the automatic ordering rules are applied to the operations.

2. Change the automatic ordering to group together the operations which use the same tool.
   - a. Click the **Ordering Options** button.
   - b. In the **Automatic Ordering Options** dialog, select **Minimize tool changes**, deselect everything else, and click **OK**.

3. Simulate the part.
   - a. Select the **Toolpaths** step from the Steps panel. This displays the **Simulation** toolbar.
   - b. Click the **3D Simulation** button.
   - c. Click the **Play** button.
     - If the **Automatic Ordering Options** dialog appears, click **OK** to close it. Notice that the simulation first performs all the spot-drills, then the drills, and then the rough and finish milling for the pockets.
   - d. Click the **Stop** button when simulation is complete to exit the simulation mode.

4. Change the automatic ordering to move the finish operations to the end of the list.
a Click the **Ordering Options** button.

b In the **Automatic Ordering Options** dialog, select **Do finish cuts last**, deselect everything else, and click **OK**.

![Automatic Ordering Options dialog](image)

This changes the order of operations in the **Operation List**.

5 **Simulate the part.**

a In the **Simulation** toolbar, click **Play**.

The finish cuts for the two pockets are now cut last.

b Click **Stop** when simulation is complete.

6 Change the automatic ordering to match the order of the features in the **Part View** panel.

a Click the **Ordering Options** button.

b Deselect everything, and click **OK**.

c Open the **Part View** panel by clicking on .

The tree view contains all the setups and features you have created.

d Click the **rect_pock2** item in the **Setup1** node, and drag it up above **hole2**.

![Part View panel](image)

7 **Simulate the part.**

a In the **Simulation** toolbar, click **Play**.

The second pocket is cut as the second feature.

b Click **Stop**.
Manual ordering options

The automatic ordering of operations determined the order by a set of rules. You can also specify an exact ordering of operations manually.

2. In the Fixed Operation Ordering dialog, select Do Not Show This Warning Again, and click OK.

3. Select the spotdrill operation for hole2 from the list, and drag it up ahead of the drill operation for hole1.

4. Simulate the part.
   a. In the Simulation toolbar, click Play. The simulation performs the operations in the new order.
   b. Click Stop when simulation is complete.

5. Selecting Automatic Ordering to return to automatic ordering.

6. Click OK to close the Automatic Operation Ordering dialog.

   If you want to erase the simulation and remove the Simulation toolbar, click Eject.
Part documentation

As well as simulating the part manufacture, the simulation generates tool and operation lists. The tools selected are based on your tool database. You can print this information to use as an operator's checklist, using the File > Print menu option.

1. Click the Details tab in the Results window to display the Manufacturing Operations sheet.

   Click the Details tab in the Results window to display the Manufacturing Operations sheet.

   **MANUFACTURING OPERATION SHEET**

   Part: milling2
   Setup: Setup1 (1 of 1)
   Date: Thursday, July 21, 2011 14:46:43
   Stock: L 5.0000 in × W 4.0000 in × T 1.0000 in
   Mat: ALUMINUM, 1.1100 BHN/40 Lb 38 HP/min

   Op 1: hole1 (spotdrill)
   F/S: 2182 RPM, 0.0088 IPR
   Tool: #1 (center 5, 0.4375 in)
   Center: 0.0000 in, 0.0000 in, 0.0000 in
   Depth: 0.4000 in
   Warning: TSB02X! Tool diameter 0.437500 is small. The default spot drill diameter and edge radius are small.

   Op 2: hole1 (drill)
   F/S: 1809 RPM, 0.0075 IPR
   Tool: #2 (TD_05000ђ12J, 0.5000 in)
   Center: 0.0000 in, 0.0000 in, 0.0000 in

2. Select the Tool List option at the top of the Details tab to show the Manufacturing Tool Detail sheet. It contains all of the tools used to create the part based on the tool crib you selected.

   **MANUFACTURING TOOL DETAIL SHEET**

   Part: milling2
   Setup: Setup1 (1 of 1)
   Date: Thursday, July 21, 2011 14:46:43
   Crib: basic
   Summary:
   Slot1: center 5 D 0.1875 in L 0
   Slot2: TD_05000ђ12J D 0.5000 in L 4
   Slot3: endmill00500.reg D 0.5000 in L 0
   Slot4: endmill0375.reg D 0.3750 in L 0

   Tool Name: center 5
   Tool Slot No.: 1
   Tool Comp. No.: 1
   Tool Offset No.: 1
   Tool Material: HSS
Controlling the strategies

You can control the strategies used to manufacture the part from the properties dialog.

1. Open the Part View panel.
2. Right-click on hole1 under the Setup1 node, and select the Properties option.

3. In the Properties dialog:
   a. Select the Strategy tab
   b. Deselect the Spot Drill option
   c. Click OK.

4. Select the Toolpaths step from the Steps panel.

5. In the Simulation toolbar, click the 3D Simulation button, and then click Play to start the simulation.
There is no spot drilling for the first hole. If you look through the operations list, there is only one spotdrill operation listed. FeatureCAM optimizes the part manufacturing process, but you control the level of automatic optimization.

6 Click Eject. This removes the Simulation toolbar.

Generating NC code

FeatureCAM generates the NC code to manufacture parts on a CNC machine. You can generate NC code after you have simulated the part, and therefore calculated the toolpaths.

1 Select the NC Code step from the Steps panel. This displays the NC Code dialog.

2 Click the NC Program button to generate the code.

---

FeatureCAM 2015 R3 Getting Started
Introduction to 2.5D milling • 21
Tool mapping

To change the location of the tools in the tool changer:

1. Select the NC Code step from the Steps panel. This displays the NC Code dialog.

2. Click the Tool Mapping button. This displays the Tool Mapping showing the current tool order.

3. To move the center drill to the 5th position in the tool changer:
   a. Select Center_5 in the table.
   b. Enter a Tool Number of 5 in the Slots frame.
   c. Click Set.

   You cannot change the number in the table.

4. Click OK to save the changes, and close the Tool Mapping dialog.

Changing the post processor

To change the post processor:

1. Select Manufacturing > Post Process from the menu. This displays the Post Options dialog.

2. Click Browse to view available post processors.

   The default folder for posts is C:\Program Files\Delcam\Examples\Posts.
3. Select your post processor and click Open.
   The new post processor is displayed in the CNC File field.

4. Click OK to exit the Post Options dialog and use the new post processor; click Cancel to exit the dialog and keep the original post processor.

5. Select the Toolpaths step from the Steps panel.

6. Run a simulation of the part to regenerate the NC code.

---

**Saving the NC code**

To save an NC program:

1. Select the NC Code step from the Steps panel. This displays the NC Code dialog.

2. Click the Save NC button in the NC Code dialog.

3. In the Save NC dialog, accept the default filename and folder, and click OK.

![Save NC dialog](image)
Introduction to turning

This tutorial shows you how to create a simple part, generate toolpaths and output the toolpaths used to machine the part.

1 Start FeatureCAM (see page 2).

2 Create a new file (see page 4), but select a Type of Turn/Mill Setup or Turning Setup.

3 Create the stock (see page 24).

4 Preparatory steps (see page 26).

5 Defining the geometry (see page 27).

6 Creating the features (see page 30).

7 Viewing the part (see page 35).

8 Simulating the toolpaths (see page 37).

9 Order of manufacturing operations (see page 38).

10 Part documentation (see page 40).

11 Changing the post processor (see page 22).

12 Generating NC code (see page 41).

13 Saving the NC code (see page 23).

Defining the stock

The stock is the initial material from which you cut your part. By default, the Stock wizard (Dimensions page) opens on the screen as soon as you create a new part. It enables you to set the shape and dimensions for the stock, the stock material, part program zero, and the coordinate system for modeling.
1 On the **Dimensions** page of the **Stock** wizard:

![Dimensions page](image)

- a. Enter an **OD** (outside diameter) of **4 (100 mm)**.
- b. Enter a **Length** of **5 (125 mm)**.
- c. Enter an **ID** (inside diameter) of **0 (0 mm)**.
- d. From the **Finish** menu button select the **Finish and Edit Properties** option.

   This displays the **Stock Properties** dialog.

2 In the **Stock Properties** dialog enter a **Z** of **0.0625 (1.5 mm)**, and click **OK**.

![Stock Properties](image)
Preparatory steps

The preparatory steps determine the coordinate system and tool crib.

1. Select Options > Turning Input Modes > 3D (XYZ) from the menu to enable you to enter coordinates as X, Y, and Z values.

2. Select Manufacturing > Set Tool Crib from the menu to display the Select Active Tool Crib dialog.

3. Select the tools option from the Crib List, and click OK.

4. To display the complete part:
   a. Click the Rotate View menu button to display the View menu:

   ![Rotate View Menu](image)

   b. Click Center All.

   ![Center All](image)
Defining the geometry

This shows you how to design your part.

1 Draw two lines:

   a Click the Geometry step in the Steps panel. This displays the Geometry Constructors dialog.

   b Select the Create more than 1 option, and click the Line from two points button. This displays the Feature/Geometry Edit bar.

   c Create two lines that define the outer profile, in the Feature/Geometry Edit bar:

      For point 1, enter an XYZ 1 of X 2 \((50 \text{ mm})\), Y 0, Z \(-3.5 \text{ (-88 mm)}\).

      For point 2, enter an XYZ 2 of X 1 \((25 \text{ mm})\), Y 0, Z \(-3.5 \text{ (-88 mm)}\).
Press **Enter**. This draws a line in the graphics window.

---

**d** Create a second line:
For point 1 enter an **XYZ 1** of **X 25 mm**, **Y 0**, **Z -3.5 (-88 mm)**.
For point 2 enter an **XYZ 2** of **X 25 mm**, **Y 0**, **Z 0**.
Press **Enter** to create a second line.

---

2 Create a chamfer to trim your lines.

**a** Click the **Geometry** step in the **Steps** panel.

**b** In the **Geometry Constructors** dialog, in the list of **Fillet** options click the **Chamfer** button.

**c** In the **Feature/Geometry Edit** bar, enter:
- A width of **0.25 (6 mm)**.
- A height of **0.25 (6 mm)**.

**d** Position your mouse pointer close to the chamfer location. The chamfer snaps into place.
e Click to place the chamfer on your drawing. The chamfer automatically trims your lines.

3 To turn the part you need to convert these three individual lines into a single curve (chain the curve).

a Select the Curves step from the Steps panel.
b In the Curves Creation dialog, select the Pick Curve Pieces button.
c In the graphics window, click locations 1, 2, and 3. Each line segment changes color when selected.
d In the Feature/Geometry Edit bar, name the curve turn, and press Enter.

4 Create third line which you will use to create a Bore feature.

a Click the Geometry step in the Steps panel.
b In the Geometry Constructors dialog, click the Line from two points button.
c In the Feature/Geometry Edit bar:
   For point 1 enter an XYZ 1 of X 0.625 (16 mm), Y 0, Z 0.
   For point 2 enter an XYZ 2 of X 0.625 (16 mm), Y 0, Z -3.75 (-94 mm).
d Press Enter.

5 To chain the bore curve:

a Select the Curves step from the Steps panel.
b In the Curves Creation dialog, select the Pick Curve Pieces button.
c  In the graphics window, click locations 4 and 5 (you select the same line twice).

![Diagram showing lines 4 and 5 selected](image)

d  In the Feature/Geometry Edit bar, name the curve bore, and press Enter.

### Creating the features

This shows you how to create the turning features.

1  Select the 2D Turned Profiles button, on the Display Mode toolbar, to switch to a simplified 2D representation of the part.

![Display Mode toolbar](image)

To open the Display Mode toolbar, select the View > Toolbars menu option, select the Display Mode option, then click OK.

2  Create a Turn feature.

   a  Click the Features step in the Steps panel.
b If you have the Turn/Mill module, the **New Feature** wizard asks you which type of feature you want to create. Select the **Turning** option, and click **Next**.

![New Feature Wizard](image)

Select Turn in the **From Curve** section, and click **Next**.

d In the **Curve** field select **turn** from the list.

Click the **Pick Curve** button to select the curve graphically. The dialog minimizes to reveal the graphics window beneath.

Click the curve you named **turn** earlier.

In this particular case, two objects are available for selection: a line and a curve. Whenever your selection needs to be clarified, FeatureCAM opens the **Select** dialog.

In the **Select** dialog, select **turn**, and click **OK**.
e From the Finish menu button, select the Finish and Create More option to continue creating features.

3 Create a Face feature.
   a In the New Feature wizard, select the Turning option, and click Next.
   b In the From Dimensions frame, select Face, and click Next.
   c On the Dimensions page:
      Enter a Thickness of 0.0625 (1.5 mm).
      Enter an Outer Diameter of 4 (100 mm).
      Enter an Inner Diameter of 0.
      Click Next.
   d Click Finish and Create More.
4 Create a Hole feature.
a In the **New Feature** wizard, select the **Turning** option, and click **Next**.

b In the **From Dimensions** frame, select **Hole**, and click **Next**.

c On the **Dimensions** page:
Enter a **Depth** of *3.75* (*94* mm).
Enter a **Diameter** of *1.0* (*24* mm).
Click **Next**.

d On the **Location** page enter a **Z** of *0*.

e Click **Finish and Create More**.

---

**5** Create a Bore feature by using the same process you used to create the Turn feature. Use the curve named **Bore**.

---

**6** Create a Groove feature.

a In the **New Feature** wizard, select the **Turning** option, and click **Next**.

b In the **From Dimensions** frame select **Groove**, and click **Next**.

c On the **Dimensions** page:
Select a **Location** of **ID**.
Select an **Orientation** of **X axis**.
Enter a **Diameter** of *1.25* (*31* mm).
Enter a Depth of **0.125** (3 mm).
Enter a Width of **0.25** (6 mm).
Leave the other settings at **0**.
Click Next.

d On the Location page enter a Z of **-3** (-75 mm).
e Click Finish and Create More.

7 Create a Thread feature.
   a In the New Feature wizard, select the Turning option, and click Next.
   b In the From Dimensions frame, select Thread, and click Next.
   c On the Dimension page:
      Select Get the thread dimensions from a standard thread.
      Select OD.
      In the Designation field select the **2.0000- 4.5 UNC** (M50-15 for metric).
      Click Next.
   d On the Dimensions page:
      Select a Thread of Right hand.
      Enter a Thread Length of **1.0** (24 mm).
      Click Next.
e Click Finish and Create More.

8 Create a Cutoff feature.
   a In the New Feature wizard, select the Turning option, and click Next.
   b In the From Dimensions frame select Cutoff, and click Next.
   c On the Dimensions page:
      Enter a Diameter of $4\text{ (100 mm)}$.
      Enter an Inner Diameter of $0$.
      Enter a Width of $0.122\text{ (3 mm)}$.
      Click Next.
   d On the Location page enter a $Z$ of $-4.5\text{ (–112 mm)}$.
   e Click Finish.

**Viewing the part**

You have been working in a 2D view.

To look at the part in a different orientation you can select one of the standard predefined views. These options are available from the Standard toolbar:
1 To return to a 3D view of the model, click the 2D Turned Profiles button, on the Display Mode toolbar.

2 Click the Isometric View button on the Standard toolbar.

3 Shade the part.
   a Open the Part View panel, and select bore1 under the Setup1 node.
   b Click the Shade Selected button on the Display Mode toolbar.
   c Select thread1 in the Part View panel.
   d Click the Shade Selected button again.

4 Click the Unshade All button on the Display Mode toolbar to return to the wireframe view.
Simulating the toolpaths

Now you have created the features, FeatureCAM automatically:
- Selects the most appropriate tools and operations;
- Recommends machining strategies;
- Calculates speeds and feeds;
- Generates toolpaths and creates the NC code.

To view the simulated toolpath:

1. Click the Toolpaths step in the Steps panel. This displays the Simulation toolbar.

2. Select the 3D Simulation option, and then click Play to start the simulation. If the Automatic Ordering Options dialog appears, click OK to close it. This accepts the default ordering options.

   This displays a solid 3D rendering of the cutting process. By default, the 3/4 view is shown when cutting or drilling the ID of the part.

   If the 3/4 view is not displayed, select Options > Simulation > Round Stock from the menu, select the 3/4 view with lathe ID work option, then click OK to close the dialog. Click the Play button on the Simulation toolbar to see the changes.

3. Click the Play to Next Operation button. This displays the face operation.
4 Repeat step 3 to view each operation until the whole part is cut.

5 Click Eject. This removes the simulation.

Order of manufacturing operations

The **Op List** tab in the **Results** window shows all of the operations needed to machine the features. A yellow warning sign next to an operation indicates a potential problem with that operation. In this case, if you see any warnings ignore them.

You can control the automatic ordering of operations by using either rules or operation templates. The 2.5D Milling tutorial looks at using rules (see page 16).

This section changes the automatic ordering by modifying the **Turn Operation** template.

**To modify the template**

1 Select the **Automatic Ordering** option on the **Op List** tab. This ensures the automatic ordering rules are applied to the operations.

2 Change the automatic ordering to group together the operations which use the same tool.
   
   a Click the **Ordering Options** button.
b In the **Automatic Ordering Options** dialog, select **Use template**.

![Automatic Ordering Options dialog](image)

3 In the **Feature Order** dialog:

a Select **Rough OD Turn**.

b Click \(\downarrow\) until **Rough OD Turn** is below **Finish ID Turn**.

c Click **OK** to close the **Feature Order** dialog.

4 Click **OK** to close the **Automatic Ordering Options** dialog.

5 Simulate the part.

a Select the **Toolpaths** step from the **Steps** panel. This displays the **Simulation** toolbar.

b Click the **3D Simulation** button, and then click the **Play** button to start the simulation.

Notice that the OD roughing and finishing now happen after the hole is drilled.

c Click the **Stop** button when simulation is complete to exit simulation mode.
Part documentation (Turning)

As well as simulating the manufacturing of the part, the simulation also generates complete tool and operations lists. The tools selected are based on your tool database. You can print all of this information for use as an operator's checklist.

1 Click the Details tab in the Results window to display the Manufacturing Operations sheet.

2 Select the Tool List option at the top of the Details tab to show the Manufacturing Tool Detail sheet. It contains all of the tools used to create the part based on the tool crib you selected.

You can review this sheet using the scroll bars.

You can print this documentation from the File > Print menu option.
Generating NC code (Turning)

FeatureCAM generates the NC code to manufacture parts on a CNC machine. You can generate NC code after you have simulated the part, and therefore calculated the toolpaths.

1. Select the NC Code step from the Steps panel. This displays the NC Code dialog.

2. Click the Display the NC Code button to generate the NC code.

### NC Code

```
N10 G1 /01 /M6 'CHANGE TO TOOL #1
N15 S1000 M41 'SET RPM TO 1000
N20 G0 X-2.2
N25 M3
N30 G1 X-0.0625 Z-2.0 F0.006
N35 G1 X0.125 Z-0.0038 F 0.006
N40 G0 X0.0 Z-0.25 T2/02 / 'CHANGE TO TOOL #2
N45 S964 M41 'SET RPM TO 954
N50 G0 X2.0125
N55 G0 X0.0 Z-0.1
N60 G1 X0.2 F0.015
N65 G0 X0.2
N70 G0 X0.2-0.9
```

Changing the post processor

To change the post processor:

1. Select Manufacturing > Post Process from the menu. This displays the Post Options dialog.

2. Click Browse to view available post processors.
   
   The default folder for posts is `C:\Program Files\Delcam\Examples\Posts`.

3. Select your post processor and click Open.
   
   The new post processor is displayed in the CNC File field.

4. Click OK to exit the Post Options dialog and use the new post processor; click Cancel to exit the dialog and keep the original post processor.

5. Select the Toolpaths step from the Steps panel.

6. Run a simulation of the part to regenerate the NC code.
Saving the NC code

To save an NC program:

1. Select the NC Code step from the Steps panel. This displays the NC Code dialog.

2. Click the Save NC button in the NC Code dialog.

3. In the Save NC dialog, accept the default filename and folder, and click OK.
Introduction to turn/mill

This tutorial introduces you to:

- Creating parts for lathes with milling capabilities.
- Mixing turning and milling features.
- Creating milling features on the outside diameter and face of the part.
- Simulating a turn/mill part.

You must have licensed the Turn/Mill option to run this tutorial.

1. Start FeatureCAM (see page 2).
2. Create a new file (see page 4), but select a Type of Turn/Mill Setup.
3. Preparatory steps (see page 44).
4. Defining the geometry (see page 44).
5. Creating the features (see page 47).
6. Viewing the part (see page 48).
7. Creating three radial holes on the face (see page 49).
8. Engraving the face (see page 50).
9. Creating three slots (see page 53).
10. Simulating the toolpaths (see page 54).
Preparatory steps

The preparatory steps define the stock and determine the coordinate system and view.

1. On the Dimensions page of the Stock wizard:
   - Select a shape of Round.
   - Enter an OD (outside diameter) of 3.
   - Enter a Length of 2.
   - Enter an ID (inside diameter) of 0.

2. Click Next until you reach the Part Program Zero page.
3. Select Align to stock face.
4. Click Next.
5. Click to position the datum of the part.
6. From the Finish menu, select the Finish button.
7. From the View menu select Center All.
8. Select Options > Turning Input Modes > Diameter (DZ) from the menu to enter coordinates as Diameter and Z values.

Defining the geometry

This shows you how to design your part.
1 Draw three lines:

a Select the **Geometry** step from the **Steps** panel. This displays the **Geometry Constructors** dialog.

![Geometry Constructors dialog]

b Select the **Create more than 1** option, and click the **Connected Lines** button. This displays the **Feature/Geometry Edit** bar.

c To create two lines that define the outer profile, in the **Feature/Geometry Edit** bar:

   For point 1 enter a **D/Z 1** of **D 2.5, Z 0**.
   For point 2 enter a **D/Z 2** of **D 2.5, Z -1.5**.
   Press **Enter** to create a line.

d Create a second line with the values:

   For point 2 enter a **D/Z 2** of **D 2.75, Z -1.5**.
   Press **Enter** to create a second line.

e Create a third line with the values:

   For point 2 enter a **D/Z 2** of **D 2.75, Z -2**.
2 Create a Fillet to trim your lines.
   a Select the Geometry step from the Steps panel.
   b In the Geometry Constructors dialog, in the list of Fillet options click the Corner Fillet button.
   c In the Feature/Geometry Edit bar, enter a radius (R) of 0.125.
   d Position your mouse pointer in the corner between the first and second lines, and click to create the fillet. The fillet automatically trims your lines.

3 To turn the part you need to chain the curves.
   a Select the Curves step from the Steps panel.
   b In the Curves Creation dialog, select the Pick Curve Pieces button.
   c In the graphics window, click the first line and then the third line.
   d In the Feature/Geometry Edit bar, name the curve Turn, and press Enter.
Creating the features

This example shows you how to create the turning features.

1. Click the 2D Turned Profiles button, on the Display Mode toolbar, to switch to a 3D representation of the part.

2. Create a Turn feature.
   a. Click the Features step in the Steps panel.
   b. In the New Feature wizard, select the Turning option, and click Next.
   c. Select Turn in the From Curve section, and click Next.
   d. In the Curve field select turn from the list.

   Click the Pick Curve button to select the curve graphically. The dialog minimizes to reveal the graphics window beneath.
Click the curve you named **Turn** earlier.
In the **Select** dialog, select **turn**, and click **OK**.

**e** Click Finish.

---

**Viewing the part**

1. On the **Standard** toolbar select the **Isometric View** button.

   ![Isometric View](image)

   *If this displays a 2D representation of the part, click the 2D Turned Profiles button, on the Display Mode toolbar.*

2. Shade the part:
   
   **a** Open the **Part View** panel, and select **turn1** under the **Setup1** node.

   **b** Click the **Shade Selected** button on the **Display Mode** toolbar.

   ![Shade Selected](image)

   **c** Click the **Unshade All** button on the **Display Mode** toolbar to return to the wireframe view.

3. To change the view to a top view; from the **Principal View** menu button, click the **Top** button.
Creating three radial holes on the face

This shows you how to add three Holes to the part.

1. To return to a 2D view of the model, click the 2D Turned Profiles button, on the Display Mode toolbar.

2. Create a Hole.
   - a. Click the Features step in the Steps panel.
   - b. In the New Feature wizard, select the Turn/Mill option, and click Next.
   - c. In the From Dimensions field, select Hole and click Next.
   - d. In the Dimensions dialog:
     - Enter a Chamfer of 0.0.
     - Enter a Depth of 1.0.
     - Enter a Diameter of 0.25.
   - e. Click Finish and Create More.

3. Create a Pattern from feature:
a In the **New Feature** wizard, select the **Turn/Mill** option, and click **Next**.

b In the **From Feature** field, select **Pattern**, and click **Next**.

c Select the hole you just created and click **Next**.

d Select **Radial** in the setup **XY plane**, and click **Next**.

e On the **Pattern - Dimensions** page:
   - Enter a **Number** of **3.0**.
   - Enter a **Diameter** of **2.0**.
   - Enter a **Spacing Angle** of **120**.
   - Enter an **Angle** of **60**.

f Click **Finish**.

g Click **Cancel**.

4 View the 3D wireframe representation of the part:

a Click the **2D Turned Profiles** button, on the **Display Mode** toolbar, to switch to a 3D representation of the part.

b Click the **Isometric View** button on the **Standard** toolbar.

---

**Engraving the face**

This shows you how to engrave the part by:

- Creating the engraving text.
- Creating a Groove feature.

---

1 Create a curve.

a Select the **Curves** step from the **Steps** panel.
b In the Curves Creation dialog, select the Curve Wizard button.

c In the Curve wizard:

Select Other methods as the construction method.
Select Text as the constructor.
Click Next.

d On the Engraving Text page, configure the text properties.

Enter a Text of **TURNMILL**.
Select a Path type of Linear.
Enter a location of X **0.0**, Y **-0.045**, Z **0.0**.
Enter an Angle of **-90**.
From the Justification list, select Center.
Enter a Scaling of X **0.4**, Y **0.4**.
Click the Font button to display the Font dialog.
From the Font list, select Machine Tool Gothic.
Enter a Size of 72.
Click OK to close the dialog.
e  Click Finish to close the wizard.

2 Create a Groove feature.
a  Select the TURNMILL text (curve1) in the graphics window.
b  Click the Features step in the Steps panel.
c  In the New Feature wizard, select the Turn/Mill option, and click Next.
d  In the From Curve field, select Groove, and click Next.
e  On the Curve page, click Next (as you have selected the text in step 2a).
f  On the Location page, click Next.
g  On the Dimensions page:
   Enter a Width of 0.0625.
   Enter a Depth of 0.02.
   Select Face.
   Select Simple (Engrave).
h  Click Finish.
Creating three slots

This shows you how to add three milled slots to the part.

1  Create a Slot feature:
   a  Click the Features step in the Steps panel.
   b  In the New Feature wizard, select the Turn/Mill option, and click Next.
   c  In the From Dimensions section, select Slot.
      Select Make a pattern from this feature, and click Next.
   d  On the Dimensions page:
      Enter a Length of 1.0.
      Enter a Width of 0.5.
      Enter a Depth of 0.25.
      Click Next.
   e  On the Patterns page select Radial around index axis, and click Next.
   f  On the Location page:
      Enter a B Angle of 90.
      Enter a Radius of 1.25.
      Enter a Z to 0.25.
      Click Next.
   g  On the Dimension page:
      Enter a Number of 3.
      Enter a Spacing Angle of 120.
   h  Click Finish.
Simulating the toolpaths

To view the simulated toolpath:

1. Click the Toolpaths step in the Steps panel. This displays the Simulation toolbar.

2. Select a CNC file for a machine that supports live tooling. For example:
   ..\Examples\Posts\TurnMill\Skeleton\skeleton-1-turret.cnc

3. Click the 3D Simulation button, and then click the Play button to start the simulation. If the Automatic Ordering Options dialog appears, click OK to close it. This accepts the default ordering options.

   The toolpaths are accurately simulated including the part rotations.

4. Click Eject. This removes the Simulation toolbar.
Introduction to 3D milling

This tutorial introduces you to:

- Modeling 3D surfaces.
- Manufacturing surfaces using surface milling features.
- Manufacturing operations.
- Tool selection.
- 3D manufacturing attributes.

You must have 3D milling to perform the examples in this chapter. These examples are only specified in inch units. You must have the basic tool crib installed.

This tutorial shows you how to create a simple part, generate toolpaths and output the toolpaths used to machine the part.

1. Start FeatureCAM (see page 2).
2. Create a new file (see page 4).
3. Defining the Stock (see page 56).
4. Defining the geometry (see page 56).
5. Creating the bottle surface (see page 60).
6. Viewing the part (see page 61).
7. Creating a surface milling feature (see page 63).
8. Simulating the toolpaths (see page 66).
Defining the Stock

The stock is the initial material from which you cut your part.

1. On the Dimensions page of the Stock wizard:

   a. Enter a Thickness of 2.
   b. Enter a Width of 3.
   c. Enter a Length of 6.25.
   d. Click Finish.

2. Click OK to accept the default values of the Stock Properties dialog.

Defining the geometry

This shows you how to design your part.

1. Select View > Toolbars from the menu, in the Toolbars frame:
   a. Select Advanced.
   b. Select Geometry.
2 Create three vertical lines:
   a On the Geometry toolbar, select Vertical from the Line menu.
   b In the Feature/Geometry Edit bar, enter an XYZ of X 1, Z 0, and press Enter.
   c Create a second line by entering an XYZ of X 5.25, Z 0, and press Enter.
   d Create a third line by entering an XYZ of X 6, Z 0, and press Enter.

3 Create three horizontal lines:
   a On the Geometry toolbar, select Horizontal from the Line menu.
   b Enter an XYZ of Y 0.5, Z 0, and press Enter.
   c Create a second line by entering an XYZ of Y 1.125, Z 0, and press Enter.
   d Create a third line by entering an XYZ of Y 1.5, Z 0, and press Enter.

4 Create a through line:
   a On the Geometry toolbar, select Point, Angle from the Line menu.
b In the **Feature/Geometry Edit** bar, enter an angle A of 30.

c In the graphics window, click at the intersection between the second horizontal and second vertical lines, at point 1, to create a through line.

5 Create arcs.

a On the **Geometry** toolbar, select 2 Pts, Radius from the **Arc** menu.

b In the **Feature/Geometry Edit** bar, enter a radius R of 0.5, and click the vertical line around point 2 and the horizontal line around point 3.

c Create the second arc:

In the **Feature/Geometry Edit** bar, enter a radius R of 1.0, and click the horizontal line around point 4 and the through line around point 5.
d Create the third arc by clicking the through line around point 6 and the horizontal line around point 7.

6 To mill the part you need to chain the curves.

a Select the Curves step from the Steps panel.

b In the Curves Creation dialog, select the Pick Curve Pieces button.

c Click at the intersection of the vertical and horizontal line at point 8 and at the intersection of the vertical and horizontal line at point 9.
Creating the bottle surface

1. Select the **Surfaces** step from the **Steps** panel.
2. In the **Surface** wizard, select **Surface of Revolution**, and click **Next**.
3. On the **Surface of Revolution** page:
   a. Enter a **Start Angle** of 0.
   b. Enter an **End Angle** of 180.
   c. FeatureCAM automatically selects your chained curve in the **Curve** field.
d In the Axis field, click the Pick line button, and select the horizontal line around point 1.

Click Finish.

---

**Viewing the part**

1. To change the view to an isometric view, click the Isometric button on the Standard toolbar.

2. Control how the part is displayed using the Viewing Options.
   a. Select Options > Viewing from the menu. This displays the Viewing Options dialog.
   b. Select the Show surface boundaries only option, and click Apply.
      This displays the surfaces as only their outer boundaries and trimmed loops. No additional lines are drawn in the interior of the surface. This makes the display of larger models much faster.
c Deselect the **Show surface boundaries only** option, and click **Apply**.
This displays the surfaces with lines in the interior of the surface. This aids visualization, but for large models, it makes the display of the part slower.

d Enter a **Surface fineness Wireframe of 20**, and click **Apply**.
This displays the surfaces with more lines. Decreasing the value of **Surface Fineness** improves the display quality but slows down the graphics.

e Click **OK** to close the dialog.

3 From the **Hide** menu on the **Advanced** toolbar, click the **Hide All Geometry** button.

4 From the **Show** menu on the **Advanced** toolbar, click the **Show all surfaces** button.

5 Click the **Shade** button, on the **Standard** toolbar, to shade the part.
Creating a surface milling feature

This shows you how to create the surface features and select the toolpath strategies.

1. On the Standard toolbar, click the Select button, and select the surface (srf1). On selection it turns red.

2. Select the Features step from the Steps panel.

3. In the New Feature wizard, in the From Surface frame, select the Surface Milling option, and click next.

4. On the Part Surface page click Next.
5 On the **New Strategy** page, select the **Choose Rough, Semi Finish, and Finish...** option, and click **Next**.

![New Strategy page](image)

6 On the **Rough** page:

   a Select the **Z Level Rough** option.
   b Select **Classify slices as 3D Pocket**.
   c Click **Next**.

![Rough page](image)
7 On the Semi-Finish page, select None, and click Next.

8 On the Finish page, select Isoline.

9 Click the Finish button.
Simulating the toolpaths

To view the simulated toolpath:

1. Click the **Toolpaths** step in the **Steps** panel. This displays the **Simulation** toolbar.

2. Click the **3D Simulation** button, and then click the **Play** button to start the simulation. If the **Automatic Ordering Options** dialog appears, click **OK** to close it. This accepts the default ordering options.

   ![Simulated toolpath](image)

   *Note how the toolpaths are accurately simulated including the part rotations.*

3. Click **Eject**. This removes the **Simulation** toolbar.
Introduction to wire EDM

This tutorial introduces you to the basics of creating wire EDM toolpaths. It looks at:

- Setting up your material and wire thickness.
- Creating wire EDM features.
- Specifying a wire EDM cutting strategy.
- Simulating wire EDM toolpaths.

You must have licensed the Wire EDM option to run this tutorial.

1. Start FeatureCAM (see page 2).
2. Create a new file (see page 4), but select a Type of Wire EDM Setup.
3. Defining the stock (see page 67).
4. Creating the profile (see page 68).
5. Creating a wire EDM feature (see page 70).
6. Simulating the wire EDM toolpath (see page 71).
7. Generating NC code (Wire EDM) (see page 73).
8. Adding a taper angle (see page 74).

Defining the stock

The preparatory steps define the stock and determine the coordinate system and view.
1 On the Dimensions page of the Stock wizard:

![Dimensions dialog]

a Enter a Thickness of **0.5**.
b Enter a Width of **4**.
c Enter a Length of **4**.
d From the Finish menu button select the Finish button.

---

**Creating the profile**

This step defines the profile.

1 Select the Curves step from the Steps panel.

2 In the Curves Creation dialog, select the Curve Wizard button.
3 In the Curve Wizard:

![Curve Wizard](image)

- Select a construction method of **Other methods**.
- Select a constructor of **Rectangle**.
- Click **Next**.

4 On the **Rectangle** page:

![Rectangle](image)

- Select **Use corner, width, and height**.
- Enter corner point of **1, 1, 0**.
- Enter a corner radius of **0.5**.
- Enter a **Width** of **2.0**.
- Enter a **Height** of **2.0**.
- Click **Finish**.
Creating a wire EDM feature

This shows you how to create a wire EDM feature.

1. Click the Features step in the Steps panel.
2. In the New Feature wizard, select the Die option in the 2 Axis frame, and click Next.

3. On the Curves page, click the Pick curve or geometry button, select the curve you created, and click Next.

4. On the Location page, click Next.
5. On the Dimensions page, enter a Thickness of 0.5 and click Next.
6. On the Start page, click Next.
7 On the Strategies page:

Simulating the wire EDM toolpath

Now you have created the features, FeatureCAM automatically:

- Selects the most appropriate tools and operations;
- Recommends machining strategies;
- Calculates speeds and feeds;
- Generates toolpaths and creates the NC code.

To view the simulated toolpath:

1. Click the Toolpaths step in the Steps panel. This displays the Simulation toolbar.

2. Click the 2D Simulation button on the Simulation toolbar.

3. Center the Simulation Speed slider to specify the simulation rate.

4. From the Simulation Next menu button, select the Play to Next Operation button to see the retract operation. If the Automatic Ordering Options dialog appears, click OK to close it.
To slow down the simulation, drag the Simulation Speed slider to the left.

5 Click the Play to Next Operation button again to see the cutoff operation.
6 Click the Play to Next Operation button again to see the final contour operation.

7 Click Eject.

---

**Generating NC code**

FeatureCAM generates the NC code to manufacture parts on a CNC machine. You can generate NC code after you have simulated the part, and therefore calculated the toolpaths.

1 Select the NC Code step from the Steps panel. This displays the NC Code dialog.

2 Click the Display the NC Code button to generate the NC code.
Adding a taper angle

This example shows you how to add a draft angle to a wire EDM part.

1. Open the Part View panel, select the die1 feature from the Setup1 node, and click the Properties button on the Feature/Geometry Edit toolbar.

2. In the Properties dialog for die1:
   
   a. Select Constant.
   
   b. Select a taper type of Left.
c  Enter a deg. of **10** as the taper angle.

d  Click **Apply**.

3  Click the Hide Stock button from the Hide menu on the Advanced toolbar.

4  Click the Isometric View button on the Standard toolbar.

5  Return back to the Properties dialog, set the taper type to **Right**, and click **Apply**.

6  Change the taper type back to **Left**, and click **OK** to close the Properties dialog.

7  Select the Toolpaths step from the Steps panel.
8 Click the 3D Simulation button, and then click the Play button.

9 Click the Select button on the Standard toolbar.

10 Click inside the curve. FeatureCAM deletes that part of the stock.

11 Click Eject.

12 From the Show menu on the Advanced toolbar, click the Show Stock button.
Index

2
2.5D milling • 8
2D turned profile • 30, 47, 48

3
3D milling • 55
3D toolpath simulation • 13, 37, 54, 66, 71

A
Arc • 56
Area clearance
  Roughing • 63
Assistance bar • 5
Automatic ordering • 16, 38

B
Bore feature • 30

C
Centre all • 26, 44
Chain curves • 27, 44, 56
Chamfer • 27
Checklist • 19
Context-sensistive help • 6
Controlling operations • 20
Controlling strategies • 20
Coordinate system • 26, 44
Curve • 27, 44, 50, 68

Arc • 56
Profile • 68
Cutoff feature • 30

D
Database • 2
  Material database • 2
  Tool database • 2
Display mode toololbar • 30
  2D turned profile • 30, 47, 48
Draft angle • 74
Duplicate holes • 49

E
Engraving • 50

F
Face feature • 30
Feature
  Bore feature • 30
  Cutoff feature • 30
  Duplicate holes • 49
  Engraving • 50
  Face feature • 30
  Groove feature • 30
  Hole feature • 9, 30, 49
  Pocket feature • 9
  Slot feature • 53
  Surface milling feature • 63
  Thread feature • 30
  Turn feature • 30, 47
  Wire EDM feature • 70
Feature/geometry edit bar • 5
Fillet • 44
Finishing • 63
Front view • 12

G
Geometry
  Hide all geometry • 61
  Show all surfaces • 61
Geometry creation • 27, 56
  Arc • 56
  Chain curves • 27, 44, 56
  Chamfer • 27
  Curve • 27, 44, 50, 68
  Draft angle • 74
  Engraving • 50
  Fillet • 44
  Line • 27, 44, 56
  Profile • 68
  Taper • 74
  Text • 50
Geometry edit bar • 5
Graphics window • 5
  Results window • 5, 15, 16, 18, 19, 38, 40
  Toolbox window • 5
Groove feature • 30

H
Help • 6
  Context-sensistive help • 6
  Help links • 6
  Online help • 6
  Technical support • 6
Help links • 6
Hide all geometry • 61
Hole feature • 9, 30, 49

I
Imperial tools • 2
Imperial units • 4
Inch tools • 2
Inch units • 4
Input modes • 26, 44
Isometric view • 12, 35, 48, 61

L
Line • 27, 44, 56

M
Machining operations • 15, 38
  Automatic ordering • 16, 38
  Controlling operations • 20
  Controlling strategies • 20
  Finishing • 63
  Manual ordering • 18
  Operation template • 38
  Ordering options • 16, 38
  Results window • 5, 15, 16, 18, 19, 38, 40
  Roughing • 63
  Semi-finishing • 63
Manual ordering • 18
Manufacturing
  NC code • 21, 41, 73
  Post processor • 22
Manufacturing operations • 15, 38
  Automatic ordering • 16, 38
  Controlling operations • 20
  Controlling strategies • 20
  Finishing • 63
  Manual ordering • 18
  Operation template • 38
  Ordering options • 16, 38
  Results window • 5, 15, 16, 18, 19, 38, 40
  Roughing • 63
  Semi-finishing • 63
Material database • 2
Menu bar • 5
Metric tools • 2
Metric units • 4
Mill/turn • 43
Milling
  2.5D milling • 8
  3D milling • 55
  Surface milling feature • 63
  Milling setup • 4

N
NC code • 21, 41, 73
  Saving NC code • 23
Tool mapping • 22

O
Online help • 6
Opening a part • 4
Operation template • 38
Operations • 15, 38
  Automatic ordering • 16, 38
  Controlling operations • 20
  Controlling strategies • 20
  Manual ordering • 18
  Operation template • 38
  Ordering options • 16, 38
Operations list • 19
Operator's checklist • 19
Ordering of operations • 15, 38
  Automatic ordering • 16, 38
  Controlling operations • 20
  Controlling strategies • 20
  Manual ordering • 18
  Operation template • 38
  Ordering options • 16, 38
Ordering options • 16, 38

P
Part
  Opening a part • 4
Part documentation • 19, 40
Pocket feature • 9
Post processor • 22
Profile • 68

R
Results window • 5, 15, 16, 18, 19, 38, 40
Roughing • 63

S
Saving NC code • 23
Screen layout • 5
Semi-finishing • 63
Setup
  Imperial units • 4
  Inch units • 4
  Metric units • 4
  Milling setup • 4
Shading • 35, 48, 61
Show all surfaces • 61
Simulating toolpaths • 13, 37, 54, 66, 71
  3D toolpath simulation • 13, 37, 54, 66, 71
Slot feature • 53
Starting FeatureCAM • 2
Status bar • 5
Stock • 8, 24, 44, 56, 67
Strategy
  Automatic ordering • 16, 38
  Controlling strategies • 20
  Manual ordering • 18
  Ordering of operations • 15, 38
  Ordering options • 16, 38
Surface creation • 60
  Surface of revolution • 60
Surface milling feature • 63
  Surface of revolution • 60

T
Taper • 74
Technical support • 6
Template
  Operation template • 38
Text • 50
Thread feature • 30
Title bar • 5
Tool database • 2
  Imperial tools • 2
  Inch tools • 2
  Metric tools • 2
Tool mapping • 22
Toolbars • 5
  Assistance bar • 5
  Display mode tolobar • 30
  Feature/geometry edit bar • 5
  Geometry edit bar • 5
  Menu bar • 5
  Status bar • 5
  Title bar • 5
Toolbox window • 5
Toolpath
  Simulating toolpaths • 13, 37, 54, 66, 71
Tools
  Imperial tools • 2
Inch tools • 2
Metric tools • 2
Tool database • 2
Tool mapping • 22
Tools list • 19
Turn feature • 30, 47
Turn/mill • 43
Turning • 24

U
Units
  Imperial tools • 2
  Imperial units • 4
  Inch tools • 2
  Inch units • 4
  Metric tools • 2
  Metric units • 4

V
Viewing the part • 12, 35, 48, 61
  Hide all geometry • 61
  Shading • 35, 48, 61
  Show all surfaces • 61
Views
  2D turned profile • 30, 47, 48
  Centre all • 26, 44
  Front view • 12
  Isometric view • 12, 35, 48, 61
  Viewing the part • 12, 35, 48, 61

W
Window
  Graphics window • 5
  Results window • 5, 15, 16, 18, 19, 38, 40
  Toolbox window • 5
Wire EDM • 67
Wire EDM feature • 70
FeatureCAM 2015 r3
Feature-based CAM software for mills, multi-tasking lathes and wire EDM
www.featurecam.com

Unlock the power of Delcam software

Visit www.delcam.tv/lz and see how Delcam software could benefit your business!

Powering your productivity

Delcam
Small Heath Business Park, Birmingham, B10 0HJ, United Kingdom
T: +44 (0) 121 766 5544  |  E: marketing@delcam.com  |  W: www.delcam.com

To contact your local reseller, visit www.delcam.com/resellers

© Copyright Delcam Ltd 2014. All trademarks are the property of their respective owners.